mountOS: Help Guide and Documentation

Getting Started

mountOS (mount Object Storage) allows seamless integration of S3-compatible cloud

storage, making it accessible and usable as a file system.

Key features include:

Managed space can only be properly comprehended by mountingthem on a
local machine

File metadata storage options: local (SQLite) or remote (PostgreSQL).
File-level history tracking for detailed record-keeping.

Offers time-based snapshots of the space, enabling access to any point in the
past from the moment the file space was created.

Encryption keys remain securely on your machine.

View and manage deleted files with ease.

Mount specific offset ranges within files as needed.

Context-based mounting options tailored to the file type.

Files are data-less and are downloaded on demand, either partially or fully,
based on the needs of the calling application.

System Requirements

macOS Sonoma (14.0) and above.

A minimum of 16GB of RAM is assumed.

200MiB or more of available hard disk space required for installation. Additional
space required for file operations.

This app is built on Apple’s File Provider framework which is inherently designed
as a data-less file system. Only Pinned files and files being uploaded will occupy
space (considered as used space); the rest are automatically evicted when the
system requires additional storage.

Internet access is necessary for accessing object store blobs and file metadata,
and greater bandwidth improves the overall experience.
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Mode

Workspace
This is the recommended mode where all files are fully managed by the mountOS app.
Hybrid

This mode combines managed workspaces with existing S3 objects. Users can use this
option to view existing S3 files and share workspace files after copying them into this
location.

To use the workspace in hybrid mode, right-click in Finder and select the “Create
Workspace” option from the context menu

Most of the features and views described in this document apply only to workspace
items. They are not applicable to non-workspace items unless explicitly stated
otherwise.
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OS Type

Choose the type of S3-compatible object store you want to configure

Storage

Set up an S3-compatible object store by providing the necessary details. Once
configured, click “Test Bucket” to validate read, write, and delete permissions.

For guidance on configuring S3 access, click the Help @ button.

Delete Policy

Refer Retention Policy section

Block Size

The block size determines the size used internally to divide files into smaller chunks for
processing or storage.

Encryption

Enable encryption to secure your data. The encryption key is securely stored in iCloud
Apple Keychain for enhanced protection. You can either provide a custom key or use the

key configured under Settings > Workspaces
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Enhance Deduplication

Refer Enhance Deduplication sectionin Settings.

Excluded Sync Extensions

Files with the specified extensions in the workspace will be excluded from syncing & to
the cloud.

Path Hide Extensions

Items with the specified extensions will have their extensions hidden in Finder. For
example, if “txt” is excluded, a file named “info.txt” will appear as “info” in Finder.
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All spaces are presented in a card view layout.

Edit Space

To modify the display name, click on the label, start typing, and press ENTER to save the
changes.

To adjust other properties, select “Show Space Configurations...” as shown above. Note
that not all properties are editable.

Open Mounted Space

Clickthe icon next to the space name to open the mounted space in Finder.

Mount Options

Read-Write Mount

This is the default mount option, allowing all operations, including reading, writing, and
modifying files.

Read-only Mount

This mount option restricts operations to viewing and reading files only. No
modifications or write actions are allowed.



Mount to Access Deleted Items
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Use this option to mount the space in a deleted view, allowing you to navigate through
folders and view deleted files while retaining the original folder structure. Edits or
deletions are not permitted in this view.

Restore Deleted ltems

Right-click on a file to open the context menu and select “Put Back to Workspace Base”
to restore it or press SPACE on a selected file to trigger a download and use it directly.

Quick Actions

& Mount PDF as...

& Open File by Range...

& Put Back to Workspace Base

Deleted Item Identification

Deleted folders are visually distinguished from non-deleted ones. Deleted files may
display a trash icon along with contextual notes, such as information about who deleted
the file.



Snapshot Mount

Provides time-based snapshots of the space, allowing access to any point in the past
from the moment the file space was created.
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Delete Items

Deleted items are removed according to the configured retention policy. Snapshot
moments may not retain those deleted files once the delete cycle is executed. To
manage this, configure “Keep deleted Items for ‘n’ days.” based on your desired
snapshot preservation window.

Future Change Highlights

Once mounted, mountOS tracks and highlights future changes to specific files or
folders as you navigate. These changes may include content updates (new versions),
renames, relocations, or deletions. Icons annotate these changes, and tooltips provide
additional contextual information for clarity.

Snapshot View Availability

Snapshot view is enabled exclusively for spaces with a retention schedule policy
configured as Snapshot.

Similar to the deleted view, edits and deletions are not permitted in this view.



File views

Users can right-click on a file to access a context menu with options tailored to that
file’s specific attributes. All file-based views are mounted in read-only mode. These
views may automatically unmount when their parent space is unmounted, while
keeping the downloaded files intact.

History / Revisions / Versions view
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Select “Show Versions” from the context menu of a file. This allows you to access its

latest version and explore all previous revisions, enabling easy retrieval and review of
historical changes.

o icon indicates the latest version of the file.

@ iconindicates the old revision of the file.

Segment view

Select “Open File by Range...” to mount a file as a range of blocks or a specific subset,
such as a particular offset range within the file. This option is available only for files that
are at least 64 KiB in size.
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Document view
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Select “Mount PDF as...” for a PDF file to access the PDF document view.

PDF documents can be mounted with various options, such as splitting by pages or

converting to images. The file will be auto downloaded first to extract metadata before
presenting these options in the modal.

Zip view
Select “Mount Zip file” for zip view.

This view allows you to extract zip file details and download files selectively without
downloading the entire source zip file.

Media view

Select “Mount Audio/Video as...” for media view.
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Media files are downloaded partially to extract metadata.

e Video Frame View: Provides options to display video content by frames, specific
time ranges (in seconds), or audio tracks.
e Audio View: Allows splitting audio files by specific time intervals (in seconds).

File Options

Pin File ©

Pinning file means keep files offline by auto download it when its mounted

Favorites ©

Mark a file as a favorite to quickly access it. All favorite, pinned, and recently accessed
files are included in the working set, which is indexed in the device’s Spotlight database
for seamless search and retrieval.

Comment &

Users can add, remove, and view comments directly from Finder.

Unmount

To unmount a space without using the main window, right-click on an empty space in
Finder and select the “Unmount” option.

@

‘ Are you sure you want to unmount
| this space?




Right-clicking on the mounted space name in the sidebar allows you to select the
“Unmount” option directly. However, this may result in a force unmount as the system
does not permit the app to display a confirmation prompt.

Space Info

Similar to the Unmount option, Space Info provides detailed information about the
currently mounted space.

Right-clicking on the mounted space name in the sidebar allows you to select this
option. However, the system prevents the application from displaying a prompt, so no
action will occur.

Share File

This option is available exclusively for direct S3 files in hybrid mode. It allows you to
share your file with others. Drag and drop your file in hybrid space to share it. You can
set restrictions by specifying an access duration for added security.

share © LRI 3 Receive Filename 0193872C-727F-7300-A855-614BC0S70A93

& Hours. k Receive ©  1Hour B texjplain
12 Hours an L #

Receive File

Similar to Share File, this option, available only in hybrid mode, allows you to generate a
URL for direct file uploads to S3. To use this feature, select “Receive File” from the
context menu in Finder.
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mountOS Extension

Open file provider settings to enable mountOS.

Settings > General > Logins & Extensions > File Provider

Space Location

All spaces are mounted inside this location.

Log Location

All logs are stored in this location.
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Unmount option

While unmounting, the user can select one of the following options as the default
behavior:

e Remove all: Deletes all files without retaining any data.
e Preserve dirty: Retains only the dirty user data.
e Preserve downloaded: Retains all downloaded data.

All derived views are unmounted with the “Preserve Downloaded” option, regardless of
the selected unmount preference.

Unmount all spaces

Force to unmount all spaces.



Open Finder

By default, all derived views are opened in Finder upon mounting. You can choose to
enable or disable this option, which will apply specifically to the Mount button in the
Spaces section
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General Settings and Delete Policy serve as default values when creating new spaces;
however, users can choose to apply different settings if needed
Enhance Deduplication

Enable the content-based chunking option to enhance deduplication efficiency, though
it may slightly impact performance. All workspace items are configured with block-size-
level deduplication by default. However, enabling this option may not always yield
better results.

Delete Policy

Refer Retention Policy section
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Retention Policy

Two modes are available for managing retention:

Snapshot

This mode allows users to mount the space in snapshot mode with the following
settings:

e Keep deleted items for N days: Specifies how long deleted items are retained.
o Keep deleted workspace for N days: Specifies how long deleted workspaces are
retained

Retention Schedule

In addition to the snapshot policy, this mode enables restricting the number of file
revisions maintained:

e Keep the last N versions of a file: Retains only the most recent N versions of a
file.

o Keep deleted items for N days: Specifies how long deleted items are retained.

o Keep deleted workspace for N days: Specifies how long deleted workspaces are
retained

Privacy Policy

Read from mountOS > Help > Privacy Policy

¢ Help

Support Documentation

Report an Issue...
Provide Feedback...

Open Source Licenses

End User License Agreement

Privacy Policy

Release MNotes

End User Agreement

Read from mountOS > Help > End User License Agreement



Quit Application
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QuiT mountOS is selected from the application menu or activated using the shortcut
CmMD + Q.

Check for Active Mounts:

e [fno spaces are mounted, the application will quit immediately.
e Ifthere are active mounts, display the following options for the user to choose
from:
e Unmount Spaces & Quit: Automatically unmount all active spaces and then
exit the application.
e Keep Spaces & Quit: Leave the active spaces mounted and close only the
application interface.
e Cancel: Abort the quit action and return to the application.

Uninstall Application

Before uninstalling mountOS, ensure all spaces are unmounted. Failing to do so may
result in stale mounted items appearing in Finder.



Support

If you need assistance or want to share your feedback, the following options are
available to help you get the support you need:

Go Through the Documentation

Begin by reviewing the documentation provided within the app. It contains detailed
information about features, functionalities.

Report an Issue

If you encounter a bug or problem while using the app, you can report it directly from the
app by navigating to:

mountOS > Help > Report an Issue...

This allows you to describe the issue and provide any necessary details through email to
help me resolve it quickly.

Provide Feedback

We value your feedback and use it to improve the app. To share your thoughts or
suggestions, go to:

mountOS > Help > Provide Feedback...

Share what’s working well and suggest areas for improvement. Your feedback is greatly
appreciated!

Logs

To troubleshoot any issues, you can locate the logs by navigating to:

Select @ icon from menu bar,
&b £ & @ = Q 2 © WedNov27 12:39:22AM

= Settings > < System > Log Location

Contact

Refer to the Contact section for detailed information.



Contact

For inquiries, assistance, or project collaborations, please contact
princejohnwesley@gmail.com

@ 2024 Prince J Wesley. All Rights Reserved.
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